frame

Sveiki apsilankę!

Jei forume lankaisi pirmą kartą, kviečiame registruotis ir prisijungti prie diskusijų.

Prisijungti Registruotis

Žaidimų serverių įdiegimas naudojant HLDSUPDATETOOL

MiXFiXMiXFiX Dalyvis (-ė)
edited 2012 balandžio 21 Į Archyvas
1. Kuriam direktoriją į kurią norime įdiegti pasirinkto žaidimo serverį.
mkdir hlds

2. Einame į sukurtą folderį
cd hlds

3. Parsisiunčiame hldsupdate tool iš steam.
wget http://storefront.steampowered.com/download/hldsupdatetool.bin

4. Duodame hldsupdatetool.bin failui skaitymo teises.
chmod +x hldsupdatetool.bin

5. Instaliuojame hldsupdate tool.
./hldsupdatetool.bin

6. Rašome
yes

7. Paleidžiame steam failiuką, kad jis atsinaujintų
./steam

8. Pradedame norimo žaidimo dedikuoto serverio parsisiuntimą
./steam -command update -game cstrike -dir .

Vietoje -game cstrike jūs galite parašyti kitokio žaidimo serverio atsisiuntimo opciją pvz

-game valve Su šia opcija bus parsiūstas Half-Life dedikuotas serveris. Žaidimų serverius kuriuos galite parsisiūsti naudojant -game yra:

** ‘game’ options for Source DS Install:

„Counter-Strike Source“
„ageofchivalry“
„alienswarm“
„cssbeta“
„diprip“
„dods“
„dystopia“
„episode1″
„esmod“
„garrysmod“
„hl2mp“
„insurgency“
„l4d_full“
„left4dead“
„left4dead2″
„left4dead2_demo“
„orangebox“
„pvkii“
„smashball“
„synergy“
„tf“
„tf_beta“
„zps“

** ‘game’ options for HL1 DS Install:

„cstrike“
„cstrike_beta“
„czero“
„dmc“
„dod“
„gearbox“
„ricochet“
„tfc“
„valve“

** ‘game’ options for Third-Party game servers:

„ageofchivalry“
„aliensvspredator“
„americasarmy3″
„brink“
„darkesthour“
„darkmessiah“
„defencealliance2″
„dinodday“
„diprip“
„dystopia“
„esmod“
„garrysmod“
„hauntedhellsreach“
„homefront“
„homefrontjpn“
„insurgency“
„killingfloor“
„killingfloor_beta“
„marenostrum“
„modernwarfare3″
„mondaynightcombat“
„naturalselection2″
„nucleardawn“
„pvkii“
„redorchestra“
„redorchestra2″
„redorchestra2beta“
„redorchestra_beta“
„serioussamhdse“
„ship“
„sin“
„smashball“
„synergy“
„tshb“
„zps“

Komentarai

  • IV_MartynasBIV_MartynasB Naujokas (-ė)
    edited 2012 balandžio 21
    Temą galima papildyti tuom, kad jei 5-ame žingsnyje pateikiama maždaug tokia klaida:
    /lib/ld-linux.so.2: bad ELF interpreter
    

    ir naudojama 64 bitų operacinė sistemą, įsidiekite libc.

    Debian:
    apt-get install libc6-i386
    

    Centos:
    yum install glibc.i386
    ARBA
    yum install glibc.i686
    
Ši diskusija uždaryta