frame

Sveiki apsilankę!

Jei forume lankaisi pirmą kartą, kviečiame registruotis ir prisijungti prie diskusijų.

Prisijungti Registruotis

kernel >2.6.22, kada?

neworldneworld Naujokas (-ė)
Sveiki,

Šito atnaujinimo laukiu jau turbūt pusę metų. Ir kada galėsiu sulaukti šio gėrio? Daugumą jūsų konkurentų jau seniai pasiupgreidino

Komentarai

  • IV_RomanLIV_RomanL Interneto vizija
    edited 2011 gruodžio 12
    Laba diena,

    atnaujinimo darbai netolimoje ateityje. Sekite naujienas.
  • neworldneworld Naujokas (-ė)
    edited 2011 gruodžio 13
    Hmm, turiu užsakęs pas jus vieną serverį JAV, o jame matau štai ką:

    root@235919:~# uname -a
    Linux 235919 2.6.32-274.7.1.el5.028stab095.1 #1 SMP Mon Oct 24 20:49:24 MSD 2011 x86_64 GNU/Linux
  • adminadmin Administrator
    edited 2011 gruodžio 13
    Naujoms OS (CentOS 6, Debian 6 ir kt.) yra emuliuojamas branduolio 2.6.32 funkcionalumas, tačiau realiai naudojamas senesnis 2.6.18 variantas.

    Šią žiemą atnaujinsim techninę įrangą ir palaipsniui numigruosim visus serverius ant 2.6.32 branduolio. Apie atnaujinimus informuosime.
  • neworldneworld Naujokas (-ė)
    edited 2012 kovo 7
    Sveiki, grįžote prie 2.6.18, nors su 2.6.32 serveris veikė kuo puikiausiai. Dabar jūsų dėka nebegaliu vėl atnaujinti/diegti programų į serverį, nes libc paketas reikalauja 2.6.22

    Ir nenustebčiau, kad po sekančio perkrovimo, serveris net nebe įsijungs (kadangi jau buvo suinstalinti paketai kurie reikalavo 2.6.22 kernelio). Kas atlygins nuostolius?

    Kodėl amerikietiškame serveryje puikiai sukasi 2.6.32? Kodėl pas konkurentus irgi gerai sukasi 2.6.32?

    O dabar pasigrožėkite klaida:

    server:~# apt-get install python
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
     g++-4.5 : Depends: gcc-4.5-base (= 4.5.3-1) but 4.5.3-9 is to be installed
               Depends: gcc-4.5 (= 4.5.3-1) but 4.5.3-9 is to be installed
     libc-dev-bin : Depends: libc6 (> 2.13) but 2.11.2-13 is to be installed
     libc6 : Depends: libc-bin (= 2.11.2-13) but 2.13-4 is to be installed
     libc6-dev : Depends: libc6 (= 2.13-4) but 2.11.2-13 is to be installed
     libstdc++6 : Depends: gcc-4.6-base (= 4.6.0-6) but 4.6.3-1 is to be installed
     libstdc++6-4.5-dev : Depends: gcc-4.5-base (= 4.5.3-1) but 4.5.3-9 is to be installed
     locales : Depends: glibc-2.13-1
     nscd : Depends: libc6 (> 2.13) but 2.11.2-13 is to be installed
     python : Depends: python2.7 (>= 2.7.2-3~) but it is not going to be installed
              Depends: python-minimal (= 2.7.2-10) but 2.6.6-14 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    

    O bandant taisyti padėti su -f:
    After this operation, 45.0 MB disk space will be freed.
    Do you want to continue [Y/n]? Y
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    Setting up libgcc1 (1:4.6.3-1) ...
    [B]FATAL: kernel too old[/B]
    Segmentation fault
    dpkg: error processing libgcc1 (--configure):
     subprocess installed post-installation script returned error exit status 139
    configured to not write apport reports
                                          Errors were encountered while processing:
     libgcc1
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
  • adminadmin Administrator
    edited 2012 kovo 7
    Galima jūsų serveriui pajungti 2.6.32 branduolio funkcionalumą. Tiesiog atsiųskite prašymą į pagalbos tarnybą.

Atsakyti

RyškusItalicStrikethroughOrdered listUnordered list
Emoji
Image
Sulyguoti kairėjeSulyguoti centreSulyguoti dešnėjeToggle HTML viewToggle full pageToggle lights
Drop image/file