frame

Sveiki apsilankę!

Jei forume lankaisi pirmą kartą, kviečiame registruotis ir prisijungti prie diskusijų.

Prisijungti Registruotis

Kaip perkelti svetainę iš var/www/ į /home/?

eugeeuge Naujokas (-ė)
edited 2012 rugsėjo 19 Į Pagalba
Sveiki!
Gal galit kas padėti. Man reikia svetainę perkelti iš katalogų /var/www/html/ į namų katalogą /home/. Bandžiau įkelti bet svetainė neveikia, paprasčiausiai neranda jos. Jeigu tai įmanoma taip padaryti, prašau pagalbėti. Svetainė aplankuose /var/www/html/ veikia. Jau beveik visą mėnesį googlinu ir niekaip nerandu.

Komentarai

  • IV_RomanLIV_RomanL Interneto vizija
    edited 2012 rugsėjo 13
    Sveiki,

    Jei pageidaujate perkelti tik vieną svetainę į kažkurį serverio katalogą, tuomet redaguokite httpd.conf failą:
    nano /etc/httpd/conf/httpd.conf
    

    Raskite eilutę "DocumentRoot" ir pakeiskite aplanko kelią serveryje. Išsaugojus nustatymus nepamirškite perkrauti serverio.

    Jei norite perkelti keletą svetainių, tuomet galite pasinaudoti šia pamoka
  • eugeeuge Naujokas (-ė)
    edited 2012 rugsėjo 13
    Taip ir darau, bet vis tiek neveikia. Bandant paleisti pagal pamoką testą [url]http://mano_domenas/nfo.php[/url] (kur mano_domenas, ten įrašau savo turimą domeną) atsiveria langas su klaida 403 Forbidden "Forbidden You don't have permission to access /nfo.php on this server."
    Pažodžiui viską sudėjau pakeičiant tik savo duomenis /var/www/ kataloguose viskas puikiai veikia, perkėlus, o nesigavus per naują sukūrus į home katalogą ir pataisius /etc/httpd/conf/httpd.conf eilutę "DocumentRoot" jau nebeveikia. Bandžiau taip pat pakeisti ir <Directory "/var/www/html"> į home, nieks nesigauna.
    Pas mane yra dvi svetainės.
    Kai veikia svetainės, randasi /var/www/mano_domenas1/ ir /var/www/mano_domenas2/ o "DocumentRoot" būna nurodytas DocumentRoot "/var/www/html"
    Kai neveikia, būna perkelta ar naujai sukūrta, randasi /dome/mano_domenas1/ ir /home/mano_domenas2/ o DocumentRoot nurodytas DocumentRoot "/home/"
  • IV_RomanLIV_RomanL Interneto vizija
    edited 2012 rugsėjo 13
    Jei konfigūruojate serverį pagal pamoką su fcgid, tokiu atveju atidžiai peržiūrėkite aplankų teises (chown).
  • eugeeuge Naujokas (-ė)
    edited 2012 rugsėjo 13
    Taip su fcgid. Dar kart1 atydžiai peržiūrėjau, net jau akis pradėjo skaudėti, aplankams suteiktos 755, viskas taip pat kaip ir tada kai buvo aplanke /var/
  • IV_RomanLIV_RomanL Interneto vizija
    edited 2012 rugsėjo 14
    Peržiūrėkite aplankų ir failų savininkus. Jei naudojate fcgid, tuomet savininkas neturėtų būti apache ar www .
  • eugeeuge Naujokas (-ė)
    edited 2012 rugsėjo 14
    Ačių, labai padėjot ir užvedėt ant kelio. Susitvarkiau ir tikriausiai klaida buvo, kad viską su php-fcgi starteriais į home direktoriją. Nežinau ar gerai kad php-fcgi starterius gražinau į /var/www/ direktoriją, bet viskas pradėjo veikti. Dar kartą ačių.
    Einant tolyn parsideda kitos bėdos, nes šiuose dalykose esu visiškai naujokas ir bandau mokytis bei suprasti. Viskas veikia lygtai, bet noriu pamėgtą Joomla įsirašyti. Susikeliu Joomlos instaliacinius failus į /public_html/, paleidžiu naršyklę, atsidaro instaliacijos langas, pasirenku kalbą lietuvių lygtai bando instaliuoti, vidury ratukas sukasi ir daugiau niekas nevyksta. Laukiau puse valandos, kitą kartą ir daugiau vis tiek stovi vietoje,tik tas ratukas sukasi. Bandiau per nauja vėl Joomlą instaliuoti, pasirinkau anglų kalbą, bet vis tiek tas pats
  • IV_RomanLIV_RomanL Interneto vizija
    edited 2012 rugsėjo 14
    Peržiūrėkite apache klaidų žurnalą:

    /var/log/httpd/error_log
  • eugeeuge Naujokas (-ė)
    edited 2012 rugsėjo 14
    Nelaibai aš klaidų žurnale suprantu, tai paskutines eilutes įdedu:
  • IV_RomanLIV_RomanL Interneto vizija
    edited 2012 rugsėjo 14
    Atverkite katalogą /var/lib/php/session/ ir jei ten yra failų, visus juos pašalinkite. Vėl mėginkite įrašyti Joomla.
  • eugeeuge Naujokas (-ė)
    edited 2012 rugsėjo 14
    Ten buvo tik vienas failas, ištryniau, serverį perkroviau, bet vis tiek tas pats
  • IV_RomanLIV_RomanL Interneto vizija
    edited 2012 rugsėjo 14
    Atidarykite failą /home/parapijasestokai.net/libraries/joomla/session/session.php ir pažiūrėkite į eilutę 676. Koks ten nurodytas kelias iki tmp aplanko /var/lib/php/session .
  • eugeeuge Naujokas (-ė)
    edited 2012 rugsėjo 14
    Suskaičiavau eilutes visas ir tuščias, štai kas gaunasi 676 eilutėje:
    /**
    * Create a new session and copy variables from the old one
    *
    * @return boolean $result true on success
    *
    * @since 11.1
    */
    public function fork()
    {
    if ($this->_state !== 'active')
    {
    // @TODO :: generated error here
    return false;
    }

    // Save values
    $values = $_SESSION;

    // Keep session config
    $trans = ini_get('session.use_trans_sid');
    if ($trans)
    {
    ini_set('session.use_trans_sid', 0);
    }
    $cookie = session_get_cookie_params();

    // Create new session id (čia gavosi 676 eilutė)
    $id = $this->_createId();

    // Kill session
    session_destroy();

    // Re-register the session store after a session has been destroyed, to avoid PHP bug
    $this->_store->register();

    // Restore config
    ini_set('session.use_trans_sid', $trans);
    session_set_cookie_params($cookie, $cookie, $cookie, $cookie);

    // Restart session with new id
    session_id($id);
    session_start();

    return true;
    }

    /**
  • IV_RomanLIV_RomanL Interneto vizija
    edited 2012 rugsėjo 14
    Ar /temp aplankas turi rašymo teises? T.y. 777.
  • eugeeuge Naujokas (-ė)
    edited 2012 rugsėjo 14
    Dar kartą pažiūrėjau, ir tikrai 777
  • IV_RomanLIV_RomanL Interneto vizija
    edited 2012 rugsėjo 14
    Atsidarykite php.ini failą:

    nano /etc/php.ini

    Raskite grafą "File Uploads" ir pažiūrėkite į eilutę:

    upload_tmp_dir = /tmp

    Ar tikrai toks kelias yra?

    Taip pat įsitikinkite jog safe mode yra išjungtas.
  • eugeeuge Naujokas (-ė)
    edited 2012 rugsėjo 14
    Taip tikrai toks ir yra, nurašau kaip parašyta php.ini faile: upload_tmp_dir = /tmp/, o safe_mod = off
  • eugeeuge Naujokas (-ė)
    edited 2012 rugsėjo 15
    Dar kartą dėkoju už pagalbą, tikrai daug ką sužinojau.
    Problemą išsprendžiau, aišku padarydamas kaip čia buvo parašyta ir taip pat katalogui /var/lib/php/session nurodydamas teises 775.
    Dar kartą ačių
  • eugeeuge Naujokas (-ė)
    edited 2012 rugsėjo 19
    Dar kartą prašau pagalbos. Niekaip nesusitvarkau su Joomla. Sutvarkius serverį pagal pamoką vienai svetainei viskas veikia kuo puikiausiai, o perdarius pagal pamoką kelioms svetainėms Joomla įsirašo kuo puikiausiai, bet paskui papildinių instaliuoti neleidžia. Lygtai pradeda instaliuoti pasikeičia Joomlos langas i 500 Internal Server Error. Iš logo štai ką gaunu:
    [Wed Sep 19 15:03:47 2012] [notice] Digest: done
    [Wed Sep 19 15:03:47 2012] [notice] Apache/2.2.15 (Unix) DAV/2 mod_fcgid/2.3.7 PHP/5.3.3 configured -- resuming normal operations
    [Wed Sep 19 15:04:02 2012] [warn] [client 78.62.205.210] mod_fcgid: HTTP request length 131518 (so far) exceeds MaxRequestLen (131072), referer: http://www.parapijasestokai.lt/administrator/index.php?option=com_installer
  • IV_RomanLIV_RomanL Interneto vizija
    edited 2012 rugsėjo 19
    Atidarykite failą /etc/httpd/conf.d/fcgid.conf ir jame raskite eilutę:
    FcgidMaxRequestLen 131072
    

    pakeiskite į
    FcgidMaxRequestLen 1073741824
    

    Perkraukite apache. Problema pašalinta.
  • eugeeuge Naujokas (-ė)
    edited 2012 rugsėjo 19
    Ačių už greitą pagalbą.
    Tik kad pas mane tokios eilutės nebuvo visai, bet įrašius suitvarkė. Ačių dar kartą
Norėdami palikti komentarą, turite prisijungti arba registruokis.