frame

Sveiki apsilankę!

Jei forume lankaisi pirmą kartą, kviečiame registruotis ir prisijungti prie diskusijų.

Prisijungti Registruotis

Apache virtuallhost konfigūracija

belosabelosa Naujokas (-ė)
Sveiki, yra 3 domenai, tarkime siteA.com, siteB.com, siteC.com. Reikia, jog veiktų:

http://siteA.com
http://www.siteA.com

http://siteB.com
http://www.siteB.com

http://siteB.com
http://www.siteB.com

Ir jei pridedamas naujas domenas arba tiesiog nėra užkonfigūruotas subdomenas turėtų nukreipti į "default". Problema, jog niekaip nepavyksta priversti jog veiktų siteA.com, jis visada rodo į default, nors www.siteA.com veikia. siteA.com yra pagrindinis domenas. Tik ištrynus iš /etc/hosts automatiškai sugeneruotą įrašą veikia taip, kaip norėčiau.

/etc/hosts
127.0.0.1 localhost.localdomain localhost
# Auto-generated hostname. Please do not remove this comment.
x.x.x.x siteA.com  siteA
::1 localhost

000-default
<VirtualHost _default_:80>
	ServerAdmin webmaster@localhost

	DocumentRoot /var/www/default
	<Directory />
		Options FollowSymLinks
		AllowOverride None
	</Directory>
	<Directory /var/www/default/>
		Options Indexes FollowSymLinks MultiViews
		AllowOverride None
		Order allow,deny
		allow from all
	</Directory>

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	<Directory "/usr/lib/cgi-bin">
		AllowOverride None
		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	</Directory>

	ErrorLog ${APACHE_LOG_DIR}/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog ${APACHE_LOG_DIR}/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

siteA.com
<VirtualHost *:80>
	ServerName siteA.com
	ServerAlias www.siteA.com
	DocumentRoot /var/www/siteA/	

</VirtualHost>

ports.conf
NameVirtualHost *:80
Listen 80
Pažymėtos temos:

Komentarai

  • IV_VygandasSIV_VygandasS Serverių ekspertas (-ė)
    edited 2013 lapkričio 5
    Šiuo atveju tikėtina, kad Jūsų serverio hostname yra toks pat, kaip ir siteA.com. Todėl šiuo atveju geriausias sprendimas būtų atlikti serverio hostname keitimą (pervadinti serverį į pvz. server.siteA.com) per mūsų klientų sistemą. Žinoma, tam prieš tai reikės atlikti siteA.com domeno, subdomeno server.siteA.com nukreipimą į Jūsų serverį.

    Tuomet "/etc/hosts" faile būtų generuoja tokia eilutė:
    # Auto-generated hostname. Please do not remove this comment.
    x.x.x.x server.siteA.com  server
    

    Ir tai nesikirstų su Jūsų Apache konfigūracija.
  • belosabelosa Naujokas (-ė)
    edited 2013 lapkričio 5
    Gal visgi išeitų apsieiti be hostname keitimo, koks apėjimas ?
  • IV_VygandasSIV_VygandasS Serverių ekspertas (-ė)
    edited 2013 lapkričio 5
    Atsižvelgiant, kad Jūs naudojat Ubuntu operacinę sistemą Jums turėtų užtekti pervadinti 000-default failą. Taip nurodant kitą virtualhost prioritetų tvarką, tam Jums reikėtų įvykdyti šias komandas:
    mv /etc/apache2/sites-enabled/000-default /etc/apache2/sites-enabled/x.000-default
    service apache2 restart
    
  • belosabelosa Naujokas (-ė)
    edited 2013 lapkričio 5
    Tokiu atveju nebekreipiama į default ir imamas pirmas domenas pagal abėcėlę. Šiuo atveju visi nesami subdomenai ir domenai rodo į siteA.com. Pervadinus xsiteA.com, visi pradeda rodyti į siteB.com
  • IV_VygandasSIV_VygandasS Serverių ekspertas (-ė)
    edited 2013 lapkričio 5
    Norėtume pasiteirauti ar Jūs bandėte atlikti minėtus pakeitimus?
  • belosabelosa Naujokas (-ė)
    edited 2013 lapkričio 5
    Taip, visa tai buvo išbandyta
  • IV_VygandasSIV_VygandasS Serverių ekspertas (-ė)
    edited 2013 lapkričio 5
    Tuomet Jūs galite pakeisti Apache tarnybai pateikiama Jūsų serverio FQDN, tai galite atlikti sukuriant failą "/etc/apache2/conf.d/fqdn" bei nurodant šiame faile eilutę:
    ServerName localhost
    

    Išsaugojus pakeitimus, perkraukit Apache tarnybą.

    Visą tai galite įvykdyti naudojant šias komandas:
    echo "ServerName localhost" | sudo tee /etc/apache2/conf.d/fqdn
    service apache2 restart
    
  • belosabelosa Naujokas (-ė)
    edited 2013 lapkričio 5
    Dabar jau veikia, esu labai dėkingas :)

Atsakyti

RyškusItalicStrikethroughOrdered listUnordered list
Emoji
Image
Sulyguoti kairėjeSulyguoti centreSulyguoti dešnėjeToggle HTML viewToggle full pageToggle lights
Drop image/file
Dedikuoti.lt
Šiame forume rasite informaciją kaip atlikti serverio administravimą, konfigūravimą, įvairių tarnybų bei papildomų aplikacijų diegimą. Taip pat pateiksime rekomendacijų, skirtų serverių saugumui, monitoringui ir optimizavimui. Kviečiame prisijungti prie dedikuotų serverių administratorių bendruomenės, dalyvauti diskusijose ir praplėsti savo žinias serverių administravimo srityje!
© 2007 - 2020 Dedikuoti.lt forumas, visos teisės saugumos.

Susisiekite

info@dedikuoti.lt